Home Forums Get Help for Klok Trouble Deleting Time Entries Reply To: Trouble Deleting Time Entries


This issue is not fixed, and it also applies to updating the project name that a previous time entry was tracked against.

We started using Klok about a month ago. I have no idea what version it is, because there doesn’t appear to be any way to get the version number to display when running it on Linux (RHEL 6.1). It’s whatever was available for download in mid-September 2011.

Regarding the problem:

I realized this morning that I had misfiled four time entries from yesterday against the wrong project. I’ve done this a couple of times in the past and other people in my workgroup had pointed out that one can select a time entry and “Change Project”. It has worked for me in the past.

I was able to do that successfully for three of the incorrect time entries, but the fourth will not work. If I double click on the time entry, click “change project” and then select the new project from the list, the bottom part of the window shows the new project. However, when I click the “Update” button, nothing happens. It will not apply the changes so that they show up in the “Week View” (can we get a “Day View”?!).

I then tried to delete the incorrect time entry, both by right-clicking and doing “Remove Entry”. No luck either.

I asked a couple other people in my workgroup if they had seen the issue, and one of them has had the same problem in the past. He indicated that exiting Klok and restarting fixed the issue. He’s using 2.3.5 on Windows.